间隔线
轻量级SEO友好型网站内容管理系统
首页 >> 教程与帮助 >> 其他问题 >> 详细内容

JS冲突问题解决方案

发布时间: 2016-01-26  点击次数:次  作者:admin

我司做的网站一般把JS分为三类:

一类是框架,如jquery,

还有一类是插件,例如superslide,

还有一类是自定义的js代码。

一般如下:

<script type="text/javascript" src="/theme/v2018/js/jquery1.91.min.js"></script>
<script type="text/javascript" src="/theme/v2018/js/jquery.plugs.yys.js"></script>
<script type="text/javascript" src="/theme/v2018/js/yongyisou.js"></script>

如果您修改网站的时候,再次引入jquery可能会造成问题。或者你引入的一些js与现有的jquery版本有冲突,也会造成一定的问题。所以我们建议您可以通过以下方式来测试问题:

(1)把所有自定义的js写入yongyisou.js中

(2)调整js的顺序,使之符合,jquery在最上边,插件次之,自定义js在最下边。

如果通过以上方式仍然解决不了,可以联系我司在线客服协助解决。


相关文章